Tonic 's lesson learned


flutter doctor 실행 시 cocoapods 관련 오류가 발생하는 경우 해결 방법

문제

flutter doctor를 실행하면 아래와 같이 에러가 발생하고 sudo gem install cocoapods를 해도 문제가 해결되지 않는다.


원인

brew로 설치한 것이 맥os가 업데이트 되면서 버전 문제가 생긴 것입니다. 문제 해결을 위해 flutter doctor는 gem으로 설치한 방법으로 안내합니다. 하지만 안내대로 sudo gem install cocoapods를 하면 gem으로 설치되긴했지만 경로가 등록되지 않았고 brew로 설치한 버전을 계속 참조하고 있기 때문에 에러가 없어지지 않습니다.


해결방법

  1. brew로 설치한 cocoapods를 제거합니다. brew uninstall cocoapods
  2. gem으로 cocoapods를 설치합니다. 설치 시 편의성을 위해 bin에 설치합니다. sudo gem install -n /usr/local/bin cocoapods

이제 다시 flutter doctor를 실행해보면 에러가 사라진 것을 볼 수 있습니다.